How to configure multi area ospf lab in cisco packet tracer

Posted: March 12, 2017 in CCNA
Tags: , ,
In this lab we will learn to configure multi area ospf using cisco packet tracer.

muti area ospf

In below Network Topology Diagram you can see there are Two area Area 0 and Area 1.
Now you have to configure OSPF such that devices in area 0 can easily communicate with devices in Area 1

 

multi area ospf lab

STEP 1:First assign ip address on each interfaces as show in above Diagram.

STEP 2:Now configure OSPD on Router R1:
Router(config)#host R1

R1(config)#router ospf 1

R1(config-router)#network 1.0.0.0 0.255.255.255 area 0

R1(config-router)#network 2.0.0.0 0.255.255.255 area 0

R1(config-router)#router-id 1.1.1.1

R1(config-router)#Reload or use "clear ip ospf process" command, for this to take effect

 

STEP 3:Configure OSPF on Router R2:
Router(config)#host R2
 R2(config-router)#network 2.0.0.0 0.255.255.255 area 0
 R2(config-router)#network 3.0.0.0 0.255.255.255 area 1
 R2(config-router)#router-id 2.2.2.2

 

STEP 4:Now finally Configure OSPF on Router R3:
Router(config)#host R3

R3(config)#router ospf 1

R3(config-router)#network 3.0.0.0 0.255.255.255 area 1

R3(config-router)#

00:30:02: %OSPF-5-ADJCHG: Process 1, Nbr 3.0.0.1 on Serial0/0/0 from LOADING to FULL, Loading Done

R3(config-router)#network 4.0.0.0 0.255.255.255 area 1

R3(config-router)#router-id 3.3.3.3

 

STEP 5: Now verify your ospf Configuration:

For verification go on middle router named R2:

Verify Route First:

 

R2#show ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

* - candidate default, U - per-user static route, o - ODR

P - periodic downloaded static route

Gateway of last resort is not set

O 1.0.0.0/8 [110/65] via 2.0.0.1, 00:54:16, Serial0/0/0

C 2.0.0.0/8 is directly connected, Serial0/0/0

C 3.0.0.0/8 is directly connected, Serial0/0/1

O 4.0.0.0/8 [110/65] via 3.0.0.2, 00:51:03, Serial0/0/1

 

 

Step 6:Now Verify Protocols running on the ROUTER r2:
R2#show ip protocols

Routing Protocol is "ospf 1"

Outgoing update filter list for all interfaces is not set

Incoming update filter list for all interfaces is not set

Router ID 3.0.0.1

Number of areas in this router is 2. 2 normal 0 stub 0 nssa

Maximum path: 4

Routing for Networks:

2.0.0.0 0.255.255.255 area 0

3.0.0.0 0.255.255.255 area 1

Routing Information Sources:

Gateway Distance Last Update

2.0.0.1 110 00:26:07

3.0.0.1 110 00:23:09

4.0.0.1 110 00:22:55

Distance: (default is 110)


 

IF YOU carefully watch the output you will find Two AREA Area 0 and Area 1 active on this Router.

 

STEP 7:Display ospf routing basic information

here you will also see the information about AREA in Details.

 

 

R2#show ip ospf

Routing Process "ospf 1" with ID 3.0.0.1

Supports only single TOS(TOS0) routes

Supports opaque LSA

It is an area border router

SPF schedule delay 5 secs, Hold time between two SPFs 10 secs

Minimum LSA interval 5 secs. Minimum LSA arrival 1 secs

Number of external LSA 0. Checksum Sum 0x000000

Number of opaque AS LSA 0. Checksum Sum 0x000000

Number of DCbitless external and opaque AS LSA 0

Number of DoNotAge external and opaque AS LSA 0

Number of areas in this router is 2. 2 normal 0 stub 0 nssa

External flood list length 0

Area BACKBONE(0)

Number of interfaces in this area is 1

Area has no authentication

SPF algorithm executed 4 times

Area ranges are

Number of LSA 4. Checksum Sum 0x024f2c

Number of opaque link LSA 0. Checksum Sum 0x000000

Number of DCbitless LSA 0

Number of indication LSA 0

Number of DoNotAge LSA 0

Flood list length 0

Area 1

Number of interfaces in this area is 1

Area has no authentication

SPF algorithm executed 5 times

Area ranges are

Number of LSA 4. Checksum Sum 0x02d69c

Number of opaque link LSA 0. Checksum Sum 0x000000

Number of DCbitless LSA 0

Number of indication LSA 0

Number of DoNotAge LSA 0

Flood list length 0

 

STEP 8: See OSPF Neighbors.
R2#show ip ospf neighbor

Neighbor ID Pri State Dead Time Address Interface

2.0.0.1 0 FULL/ - 00:00:36 2.0.0.1 Serial0/0/0

4.0.0.1 0 FULL/ - 00:00:34 3.0.0.2 Serial0/0/1

 

SEE Little More details suing below command.

 

R2#show ip ospf neighbor detail

Neighbor 2.0.0.1, interface address 2.0.0.1

In the area 0 via interface Serial0/0/0

Neighbor priority is 0, State is FULL, 7 state changes

DR is 0.0.0.0 BDR is 0.0.0.0

Options is 0x00

Dead timer due in 00:00:39

Neighbor is up for 01:00:13

Index 1/1, retransmission queue length 0, number of retransmission 0

First 0x0(0)/0x0(0) Next 0x0(0)/0x0(0)

Last retransmission scan length is 0, maximum is 0

Last retransmission scan time is 0 msec, maximum is 0 msec

Neighbor 4.0.0.1, interface address 3.0.0.2

In the area 1 via interface Serial0/0/1

Neighbor priority is 0, State is FULL, 6 state changes

DR is 0.0.0.0 BDR is 0.0.0.0

Options is 0x00

Dead timer due in 00:00:36

Neighbor is up for 00:57:15

Index 2/2, retransmission queue length 0, number of retransmission 0

First 0x0(0)/0x0(0) Next 0x0(0)/0x0(0)

Last retransmission scan length is 0, maximum is 0

Last retransmission scan time is 0 msec, maximum is 0 msec

 

Advertisements

Leave a Reply

Please log in using one of these methods to post your comment:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s