Route Redistribution between RIP and EIGRP

Posted: 18 Jan 2018 in CCNP
Tags: ,

In this lab we will see how to configure route redistribution between RIP and EIGRP. We use Route Distribution because Route Redistribution allows routes from one routing protocol to be advertised into another routing protocol.It helps network admin to make it possible to communicate between different routing protocols.It is also possible to redistribute from one routing protocol to the same routing protocol, such as between two separate OSPF domains (distinguished by unique process ID’s). Static routes and connected interfaces can be redistributed into a routing protocol as well.  While configuring route redistribution Routing metrics are a key consideration.

You can Also Read:
Route Redistribution Between OSPF and EIGRP
Route Redistribution between RIP and OSPF Routing domain

 

route redistribution

Step 1:Assign ip address on router interfaces.
Step 2:Configure RIP Routing on R1:
r1(config)#router rip

r1(config-router)#version 2

r1(config-router)#network 1.0.0.0

r1(config-router)#network 3.0.0.0

r1(config-router)#exit

r1(config)#do write

Building configuration...

[OK]

r1(config)#
Step3: configure RIP and EIGRP on Router r2:

 

r2(config)#router rip

r2(config-router)#version 2

r2(config-router)#network 3.0.0.0

r2(config-router)#exit

r2(config)#do write

Building configuration...

[OK]

r2(config)#

 

EIGRP on R2
r2(config)#router eigrp 1

r2(config-router)#network 4.0.0.0

r2(config-router)#exit

r2(config)#do write

Building configuration...

[OK]

r2(config)#
Step4: configure EIGRP on Router R3:

 

r3(config)#router eigrp 1

r3(config-router)#network 4.0.0.0

r3(config-router)#network 5.0.0.0

r3(config-router)#exit

r3(config)#do write

Building configuration...

[OK]

r3(config)#

 

Step 5: Redistribute RIP Routes in to EIGRP on R2
r2(config)#router rip

r2(config-router)#redistribute eigrp 1 metric 1

r2(config-router)#

 

Step 6:Redistribute EIGRP Routes in to RIP on R2
r2(config)#router eigrp 1

r2(config-router)#redistribute rip metric 10000 1 255 1 1500

r2(config-router)#exit

r2(config)#do write

Building configuration...

[OK]

r2(config)#

 

Code Explanation: #redistribute rip metric  10000  1  255  1   1500
EIGRP was configured to redistribute all rip routes, and apply a metric of 10000 (bandwidth), 1 (delay), 255 (reliability), 1 (load), and 1500 (MTU) to the redistributed routes.

Step 7:Check Routing table

 

On r3
r3#show ip route

D EX 1.0.0.0/8 [170/258816] via 4.0.0.1, 00:03:04, FastEthernet0/0

D EX 3.0.0.0/8 [170/258816] via 4.0.0.1, 00:03:04, FastEthernet0/0

C 4.0.0.0/8 is directly connected, FastEthernet0/0

C 5.0.0.0/8 is directly connected, FastEthernet0/1

on r2
r2#show ip route

R 1.0.0.0/8 [120/1] via 3.0.0.1, 00:00:22, FastEthernet0/0

C 3.0.0.0/8 is directly connected, FastEthernet0/0

C 4.0.0.0/8 is directly connected, FastEthernet0/1

D 5.0.0.0/8 [90/30720] via 4.0.0.2, 00:07:48, FastEthernet0/1

 

On r1:
r1#show ip route

C 1.0.0.0/8 is directly connected, FastEthernet0/0

C 3.0.0.0/8 is directly connected, FastEthernet0/1

R 4.0.0.0/8 [120/1] via 3.0.0.2, 00:00:12, FastEthernet0/1

R 5.0.0.0/8 [120/1] via 3.0.0.2, 00:00:12, FastEthernet0/1

 

Step 8:Check Connection using PING.

Test configuration from PC0

PC>ipconfig

FastEthernet0 Connection:(default port)

Link-local IPv6 Address.........: FE80::20A:41FF:FE75:7366

IP Address......................: 1.0.0.2

Subnet Mask.....................: 255.0.0.0

Default Gateway.................: 1.0.0.1



PC>ping 5.0.0.2

Pinging 5.0.0.2 with 32 bytes of data:

Reply from 5.0.0.2: bytes=32 time=0ms TTL=125

Reply from 5.0.0.2: bytes=32 time=0ms TTL=125

Reply from 5.0.0.2: bytes=32 time=0ms TTL=125

Reply from 5.0.0.2: bytes=32 time=1ms TTL=125

Ping statistics for 5.0.0.2:

Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),

Approximate round trip times in milli-seconds:

Minimum = 0ms, Maximum = 1ms, Average = 0ms

PC>
Advertisements
Comments
  1. Victor rodriguez says:

    Hello mr

    What mean
    r2(config-router)#redistribute rip metric 10000 1 255 1 1500

    Metric 10000 1 255 1 1500????

    Please help

    Liked by 2 people

Leave a Reply

Please log in using one of these methods to post your comment:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google+ photo

You are commenting using your Google+ account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s

This site uses Akismet to reduce spam. Learn how your comment data is processed.