RIP Routing Lab with 5 Routers:Cisco Packet Tracer Lab

RIP Routing Lab with 5 Routers: Cisco Packet Tracer Lab.

This Lab is all about RIP Routing Configuration. I have taken total 5 Routers to demonstrate this Routing Lab using Cisco Packet Tracer. Since this lab is focused on RIP routing, I will mention RIP routing Configuration steps only and no ip address basic things. I want to assume here that you already know how to assign ip address on routers. But If You don’t know i have already written article on that.

In RIP Routing we tell each router about directly connected networks only.

There are two types of RIP routing:

RIPv1 and RIPv2 and both configurations are same. Means no difference in their configuration commands.

RIP Routing Configuration on Router R1:

R1(config)#router rip
R1(config-router)#version 2
R1(config-router)#network 172.168.0.0
R1(config-router)#network 2.0.0.0
R1(config-router)#

RIP Routing Configuration on Router R2:

R2(config)#router rip
R2(config-router)#version 2
R2(config-router)#network 2.0.0.0
R2(config-router)#network 3.0.0.0
R2(config-router)#

RIP Routing Configuration on Router R3:

R3(config)#router rip
R3(config-router)#version 2
R3(config-router)#network 3.0.0.0
R3(config-router)#network 4.0.0.0
R3(config-router)#

RIP Routing Configuration on Router R4:

R4(config)#router rip
R4(config-router)#version 2
R4(config-router)#net 4.0.0.0
R4(config-router)#net 5.0.0.0

RIP Routing Configuration on Router R5:

R5(config)#router rip
R5(config-router)#version 2
R5(config-router)#network 192.168.1.0
R5(config-router)#network 5.0.0.0

Routing Configuration check:

R1#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

C    2.0.0.0/8 is directly connected, FastEthernet0/1
R    3.0.0.0/8 [120/1] via 2.0.0.2, 00:00:15, FastEthernet0/1
R    4.0.0.0/8 [120/2] via 2.0.0.2, 00:00:15, FastEthernet0/1
R    5.0.0.0/8 [120/3] via 2.0.0.2, 00:00:15, FastEthernet0/1
C    172.0.0.0/8 is directly connected, FastEthernet0/0
R    192.168.1.0/24 [120/4] via 2.0.0.2, 00:00:15, FastEthernet0/1
R1#

Routing Protocol verification:

R1#show ip protocols
Routing Protocol is "rip"
Sending updates every 30 seconds, next due in 7 seconds
Invalid after 180 seconds, hold down 180, flushed after 240
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Redistributing: rip
Default version control: send version 2, receive 2
  Interface             Send  Recv  Triggered RIP  Key-chain
  FastEthernet0/0       2     2     
  FastEthernet0/1       2     2     
Automatic network summarization is in effect
Maximum path: 4
Routing for Networks:
	2.0.0.0
	172.168.0.0
Passive Interface(s):
Routing Information Sources:
	Gateway         Distance      Last Update
	2.0.0.2              120      00:00:25
Distance: (default is 120)

Leave a Reply

Please log in using one of these methods to post your comment:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google photo

You are commenting using your Google account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s

This site uses Akismet to reduce spam. Learn how your comment data is processed.