Route Redistribution Between OSPF and EIGRP

Posted: 18 Jan 2018 in CCNP
Tags:

This is a Route Redistribution between OSPF and EIGRP configuration Lab. In this tutorial we will learn how to configure Route Redistribution between OSPF and EIGRP using Cisco Packet Tracer.I have made a step wise tutorial showing redistribution process between EIGRP and OSPF and also performed Network connection Testing after Configuration.If you are preparing for CCNP Certification this lab will help you score and learn Route distribution Questions.

Redistribution is done to enable communication between routers running different protocols.

For Example here in this lab you can see two different protocols EIGRP and OSPF.

You can also Learn:
Route Redistribution between RIP and OSPF Routing domain
Route Redistribution between RIP and EIGRP

 

eigrp ospf redistribution lab

Step 1: Assign IP Address on Each Router Interfaces First.
Step 2:Configure EIGRP on Router R1:
r1>enable

r1#config t

Enter configuration commands, one per line. End with CNTL/Z.

r1(config)#router eigrp 100

r1(config-router)#network 1.0.0.0

r1(config-router)#network 3.0.0.0

r1(config-router)#exit

r1(config)#do write

Building configuration...

[OK]

r1(config)#
Step 3: Configure EIGRP and OSPF on Router R2:
r2>enable

r2#config t

Enter configuration commands, one per line. End with CNTL/Z.

r2(config)#router eigrp 100

r2(config-router)#network 3.0.0.0

 

r2(config-router)#exit

r2(config)#router ospf 100

r2(config-router)#network 4.0.0.0 0.255.255.255 area 0

r2(config-router)#exit

r2(config)#do write

Building configuration...

[OK]

r2(config)#
Step 4: Configure OSPF Routing Protocol on Router R3:
r3>enable

r3#config t

Enter configuration commands, one per line. End with CNTL/Z.

r3(config)#router ospf 100

r3(config-router)#network 4.0.0.0 0.255.255.255 area 0

r3(config-router)#network 5.0.0.0 0.255.255.255 area 0

r3(config-router)#exit

 

 

 

Step 5: redistribute EIGRP routes into OSPF.

 

r2(config)#router eigrp 100

r2(config-router)#redistribute ospf 100 metric 1000 100 255 1 1500

r2(config-router)#

 

 

Step 6: redistribute OSPF routes into EIGRP.
r2(config)#router ospf 100

r2(config-router)#redistribute eigrp 100 metric 1 subnets

 

Step 7: Test routing Connectivity from PC.

 

PC>ipconfig

FastEthernet0 Connection:(default port)

Link-local IPv6 Address.........: FE80::20A:41FF:FE75:7366

IP Address......................: 1.0.0.2

Subnet Mask.....................: 255.0.0.0

Default Gateway.................: 1.0.0.1

 

PC>ping 5.0.0.2

Pinging 5.0.0.2 with 32 bytes of data:

Request timed out.

Reply from 5.0.0.2: bytes=32 time=0ms TTL=125

Reply from 5.0.0.2: bytes=32 time=0ms TTL=125

Reply from 5.0.0.2: bytes=32 time=0ms TTL=125

Ping statistics for 5.0.0.2:

Packets: Sent = 4, Received = 3, Lost = 1 (25% loss),

Approximate round trip times in milli-seconds:

Minimum = 0ms, Maximum = 0ms, Average = 0ms

PC>

 

Step 8:Check routing Table

 

r1#show ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

* - candidate default, U - per-user static route, o - ODR

P - periodic downloaded static route

Gateway of last resort is not set

C 1.0.0.0/8 is directly connected, FastEthernet0/0

C 3.0.0.0/8 is directly connected, FastEthernet0/1

D EX 4.0.0.0/8 [170/2588160] via 3.0.0.2, 00:03:15, FastEthernet0/1

D EX 5.0.0.0/8 [170/2588160] via 3.0.0.2, 00:03:15, FastEthernet0/1

r1#

 

r3#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
 D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
 N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
 E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
 i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
 * - candidate default, U - per-user static route, o - ODR
 P - periodic downloaded static route

Gateway of last resort is not set

O E2 1.0.0.0/8 [110/1] via 4.0.0.1, 00:02:16, FastEthernet0/0
O E2 3.0.0.0/8 [110/1] via 4.0.0.1, 00:02:16, FastEthernet0/0
C 4.0.0.0/8 is directly connected, FastEthernet0/0
C 5.0.0.0/8 is directly connected, FastEthernet0/1
r3#

hacking training

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google+ photo

You are commenting using your Google+ account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

w

Connecting to %s