RIP configuration on cisco router

Posted: April 1, 2015 in CCNA
Tags: ,

Learn how to configure ripv1(Routing Information Protocol) over cisco routers.In this tutorial we will learn how to configure rip over routers.So here using one example i will demonstrate how to configure routing information protocol step wise.This article will help you if you are preparing for ccna certification exam or learning networking.Hence you can easily learn how to configure rip on a cisco router using a cisco packet tracer.In below example i have taken three routers to perform routing information protocol configuration lab.I have also mentioned all commands needed to troubleshoot rip.

rip configuration

 

Now we are going to configure routers step wise:

we do the whole configuration in two parts.In First part we assign ip address to each and every interfaces of routers,set clock rates on router interface and up network inteface using no shut command.In the second part we enable rip routing process,specifying a RIP version and associates a network  with a RIP routing process.

Lets begin with first part:

Router>enable
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname R1
R1(config)#int fa0/0
R1(config-if)#ip address 1.0.0.1 255.0.0.0
R1(config-if)#no shut

R1(config-if)#exit
R1(config)#int se0/0/1
R1(config-if)#ip address 4.0.0.1 255.0.0.0
R1(config-if)#clock rate 64000
R1(config-if)#no shut

R1(config-if)#exit
R1(config)#int se0/0/0
R1(config-if)#ip address 2.0.0.1 255.0.0.0
R1(config-if)#clock rate 64000
R1(config-if)#no shut

 

 

Router>enable
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname R2
R2(config)#int se0/0/0
R2(config-if)#ip address 2.0.0.2 255.0.0.0
R2(config-if)#no shut
R2(config)#int se0/0/1
R2(config-if)#ip address 3.0.0.1 255.0.0.0
R2(config-if)#clock rate 64000
R2(config-if)#no shut

 

Router>enable
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname R3
R3(config)#int fa0/0
R3(config-if)#ip address 5.0.0.1 255.0.0.0
R3(config-if)#no shut

R3(config-if)#exit
R3(config)#int se0/0/1
R3(config-if)#ip address 3.0.0.2 255.0.0.0
R3(config-if)#no shut
R3(config-if)#exit
R3(config-if)#int se0/0/0
R3(config-if)#ip address 4.0.0.2 255.0.0.0
R3(config-if)#no shut

Start configuring part2:
Configuring rip version 1 on a network.

 

R2(config-if)#exit
R2(config)#router rip
R2(config-router)#version 1
R2(config-router)#network 2.0.0.0
R2(config-router)#network 3.0.0.0
R2(config-router)#exit

R3(config-if)#exit
R3(config)#router rip
R3(config-router)#version 1
R3(config-router)#network 3.0.0.0
R3(config-router)#network 4.0.0.0
R3(config-router)#network 5.0.0.0
R3(config-router)#exit

R1(config)#router rip
R1(config-router)#version 1
R1(config-router)#network 2.0.0.0
R1(config-router)#network 4.0.0.0
R1(config-router)#network 1.0.0.0
R1(config-router)#exit

 

RIP TROUBLESHOOTING COMMANDS:

Verify your configuration:(see highlighted portion or color portion)

R2#show ip protocols
Routing Protocol is “rip”
Sending updates every 30 seconds, next due in 28 seconds
Invalid after 180 seconds, hold down 180, flushed after 240
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Redistributing: rip
Default version control: send version 1, receive 1
Interface Send Recv Triggered RIP Key-chain
Serial0/0/1 1 1
Serial0/0/0 1 1
Automatic network summarization is in effect
Maximum path: 4
Routing for Networks:
2.0.0.0
3.0.0.0
Passive Interface(s):
Routing Information Sources:
Gateway Distance Last Update
2.0.0.1 120 00:00:04
3.0.0.2 120 00:00:28
Distance: (default is 120)

 

R2#show ip route
Codes: C – connected, S – static, I – IGRP, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2, E – EGP
i – IS-IS, L1 – IS-IS level-1, L2 – IS-IS level-2, ia – IS-IS inter area
* – candidate default, U – per-user static route, o – ODR
P – periodic downloaded static route

Gateway of last resort is not set

R 1.0.0.0/8 [120/1] via 2.0.0.1, 00:00:15, Serial0/0/0
C 2.0.0.0/8 is directly connected, Serial0/0/0
C 3.0.0.0/8 is directly connected, Serial0/0/1
R 4.0.0.0/8 [120/1] via 2.0.0.1, 00:00:15, Serial0/0/0
[120/1] via 3.0.0.2, 00:00:08, Serial0/0/1
R 5.0.0.0/8 [120/1] via 3.0.0.2, 00:00:08, Serial0/0/1

 

R2#show ip rip database
1.0.0.0/8 auto-summary
1.0.0.0/8
[1] via 2.0.0.1, 00:00:11, Serial0/0/0
2.0.0.0/8 auto-summary
2.0.0.0/8 directly connected, Serial0/0/0
3.0.0.0/8 auto-summary
3.0.0.0/8 directly connected, Serial0/0/1
4.0.0.0/8 auto-summary
4.0.0.0/8
[1] via 2.0.0.1, 00:00:11, Serial0/0/0 [1] via 3.0.0.2, 00:00:20, Serial0/0/1
5.0.0.0/8 auto-summary
5.0.0.0/8
[1] via 3.0.0.2, 00:00:20, Serial0/0/1

 

R2#show ip route rip
R 1.0.0.0/8 [120/1] via 2.0.0.1, 00:00:01, Serial0/0/0
R 4.0.0.0/8 [120/1] via 2.0.0.1, 00:00:01, Serial0/0/0
[120/1] via 3.0.0.2, 00:00:12, Serial0/0/1
R 5.0.0.0/8 [120/1] via 3.0.0.2, 00:00:12, Serial0/0/1

 

R2#show ip interface brief
Interface IP-Address OK? Method Status Protocol

FastEthernet0/0 unassigned YES unset administratively down down

FastEthernet0/1 unassigned YES unset administratively down down

Serial0/0/0 2.0.0.2 YES manual up up

Serial0/0/1 3.0.0.1 YES manual up up

Serial0/1/0 unassigned YES unset administratively down down

Serial0/1/1 unassigned YES unset administratively down down

Vlan1 unassigned YES unset administratively down down

 

R2#show clock
*0:50:2.381 UTC Mon Mar 1 1993

 

 

R2#show protocols
Global values:
Internet Protocol routing is enabled
FastEthernet0/0 is administratively down, line protocol is down
FastEthernet0/1 is administratively down, line protocol is down
Serial0/0/0 is up, line protocol is up
Internet address is 2.0.0.2/8
Serial0/0/1 is up, line protocol is up
Internet address is 3.0.0.1/8
Serial0/1/0 is administratively down, line protocol is down
Serial0/1/1 is administratively down, line protocol is down
Vlan1 is administratively down, line protocol is down

Note:RIP Version 1 does not support authentication

Leave a Reply

Please log in using one of these methods to post your comment:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s