cisco packet tracer lab:configuring rip routing lab using two routers

Posted: 22 Apr 2018 in CCNA
Tags: , , ,

This is a RIP Routing Configuration Lab using two Routers. In this article i have shown how to configure rip routing using cisco packet tracer. This is an example lab showing rip routing and it’s configuration having two routers and three network as mentioned in below topology diagram. I have tried my best to make it easy for you to learn rip routing in just few simple steps. I have also tried my best to explain the rip routing code and there usage and why they are necessary.Apart from RIP routing configuration I have also included RIP routing Troubleshooting command which will helps you to troubleshoot your network problem where RIP Routing is configured.

Step 1: Draw the topology Diagram with the help of cisco packet tracer as i have mentioned below.

rip routing

 

Step 2: Configure IP Address on Both Routers R1 and R2:
Assign IP Address on Router R1 Interfaces:

 

Router>enable

Router#config t

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#host R1

R1(config)#int fa0/0

R1(config-if)#ip add 2.0.0.1 255.0.0.0

R1(config-if)#no shut

R1(config-if)#exit

R1(config)#int fa0/1

R1(config-if)#ip add 3.0.0.1 255.0.0.0

R1(config-if)#no shut

 

Assign IP Address on Router R2 Interfaces:

 

Router>enable

Router#config t

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#host R2

R2(config)#int fa0/0

R2(config-if)#ip add 4.0.0.1 255.0.0.0

R2(config-if)#no shut

 

R2(config-if)#exit

R2(config)#int fa0/1

R2(config-if)#ip add 3.0.0.2 255.0.0.0

R2(config-if)#no shut

 

Step 3: Assign IP address on PC0 and PC2:

Step 3: RIP routing Configuration on Router R1:

R1>enable

R1#config t

Enter configuration commands, one per line. End with CNTL/Z.

R1(config)#router rip

R1(config-router)#version 2

R1(config-router)#network 2.0.0.0

R1(config-router)#network 3.0.0.0

R1(config-router)#exit

R1(config)#do write

Building configuration...

[OK]

R1(config)#

 

Step 4: RIP routing Configuration on Router R2:

 

R2>enable

R2#config t

Enter configuration commands, one per line. End with CNTL/Z.

R2(config)#router rip

R2(config-router)#version 2

R2(config-router)#network 3.0.0.0

R2(config-router)#network 4.0.0.0

R2(config-router)#exit

R2(config)#do write

Building configuration...

[OK]

 

Step 5: Check RIP routing Table

Check routing table on Router R1 using below command.

 

R1#show ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

* - candidate default, U - per-user static route, o - ODR

P - periodic downloaded static route

Gateway of last resort is not set

C 2.0.0.0/8 is directly connected, FastEthernet0/0

C 3.0.0.0/8 is directly connected, FastEthernet0/1

R 4.0.0.0/8 [120/1] via 3.0.0.2, 00:00:00, FastEthernet0/1

 

Step 6: Check RIP Routing Protocol

Check Routing Protocols configured on Router R1 using below command:

 

R1#show ip protocols

Routing Protocol is "rip"

Sending updates every 30 seconds, next due in 25 seconds

Invalid after 180 seconds, hold down 180, flushed after 240

Outgoing update filter list for all interfaces is not set

Incoming update filter list for all interfaces is not set

Redistributing: rip

Default version control: send version 2, receive 2

Interface Send Recv Triggered RIP Key-chain

FastEthernet0/0 2 2

FastEthernet0/1 2 2

Automatic network summarization is in effect

Maximum path: 4

Routing for Networks:

2.0.0.0

3.0.0.0

Passive Interface(s):

Routing Information Sources:

Gateway Distance Last Update

3.0.0.2 120 00:00:05

Distance: (default is 120)


Step 7: Check RIP Routing Database

 

R1#show ip rip database

2.0.0.0/8 auto-summary

2.0.0.0/8 directly connected, FastEthernet0/0

3.0.0.0/8 auto-summary

3.0.0.0/8 directly connected, FastEthernet0/1

4.0.0.0/8 auto-summary

4.0.0.0/8

[1] via 3.0.0.2, 00:00:25, FastEthernet0/1
Advertisements

Leave a Reply

Please log in using one of these methods to post your comment:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google+ photo

You are commenting using your Google+ account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s

This site uses Akismet to reduce spam. Learn how your comment data is processed.