RIPv2 configuration having six routers

Posted: April 14, 2015 in CCNA
Tags: ,

Learn to configure RIPv2 on a complex network having six routers.To make you learn to configure even very complex routing easier i have taken this example Lab having six routers and four switches.I found many students during their ccna training very easily configure routing having two routers or three routers but when they have to solve or configure a network having more than four routers they get confused while routing.Even some of students get confused in assigning correct ip addresses and detect proper network.Here in this Lab i have taken a little complex example and solve it in few simple steps.This will help ccna learning students to configure and understand complex network easily.If you are preparing for CCNA Exam this article is for you.

complex ripv2

Here in this Lab Network in use are

10.0.0.0/8

20.0.0.0/8

30.0.0.0/8

40.0.0.0/8

50.0.0.0/8

60.0.0.0/8

70.0.0.0/8

80.0.0.0/8

90.0.0.0/8

110.0.0.0/8

All four switches used in this Lab are in same network say 110.0.0.0/8.

 

Configuration on Router0

First we configure router0 interfaces,assign ip address on each interface of router0 and  set clock rate where required and then we configure router rip version2.

interface Serial0/0/0

ip address 40.0.0.2 255.0.0.0

interface Serial0/0/1

ip address 50.0.0.2 255.0.0.0

clock rate 64000

 

router rip

version 2

network 40.0.0.0

network 50.0.0.0

 

Configuration on Router 2

 we configure router2 interfaces,assign ip address on each interface of router2 and  set clock rate where required and then we configure router rip version2.

interface FastEthernet0/0

ip address 110.0.0.1 255.0.0.0

interface FastEthernet0/1

ip address 20.0.0.1 255.0.0.0

interface Serial0/0/0

ip address 30.0.0.1 255.0.0.0

interface Serial0/0/1

ip address 40.0.0.1 255.0.0.0

clock rate 64000

 

router rip

version 2

network 20.0.0.0

network 30.0.0.0

network 40.0.0.0

network 110.0.0.0

 

Configuration on Router 3

we configure router3 interfaces,assign ip address on each interface of router3 and  set clock rate where required and then we configure router rip version2.

interface FastEthernet0/0

ip address 110.0.0.3 255.0.0.0

interface FastEthernet0/1

ip address 10.0.0.1 255.0.0.0

interface Serial0/0/0

ip address 60.0.0.1 255.0.0.0

clock rate 64000

interface Serial0/0/1

ip address 30.0.0.2 255.0.0.0

clock rate 64000

 

router rip

version 2

network 10.0.0.0

network 30.0.0.0

network 60.0.0.0

network 110.0.0.0

 

Configuration on Router 4

we configure router4 interfaces,assign ip address on each interface of router4 and  set clock rate where required and then we configure router rip version2.

interface FastEthernet0/0

ip address 110.0.0.2 255.0.0.0

interface FastEthernet0/1

ip address 80.0.0.1 255.0.0.0

interface Serial0/0/0

ip address 100.0.0.2 255.0.0.0

interface Serial0/0/1

ip address 50.0.0.1 255.0.0.0

 

router rip

version 2

network 50.0.0.0

network 80.0.0.0

network 100.0.0.0

network 110.0.0.0

 

Configuration on Router 5

we configure router5 interfaces,assign ip address on each interface of router5 and  set clock rate where required and then we configure router rip version2.

interface FastEthernet0/0

ip address 110.0.0.4 255.0.0.0

interface FastEthernet0/1

ip address 90.0.0.1 255.0.0.0

interface Serial0/0/0

ip address 70.0.0.2 255.0.0.0

interface Serial0/0/1

ip address 100.0.0.1 255.0.0.0

clock rate 64000

 

router rip

version 2

network 70.0.0.0

network 90.0.0.0

network 100.0.0.0

network 110.0.0.0

 

Configuration on Router 6

we configure router6 interfaces,assign ip address on each interface of router6 and  set clock rate where required and then we configure router rip version2.

interface Serial0/0/0

ip address 60.0.0.2 255.0.0.0

interface Serial0/0/1

ip address 70.0.0.1 255.0.0.0

clock rate 64000

 

router rip

version 2

network 60.0.0.0

network 70.0.0.0

 

Now Test and Troubleshoot your RIPv2 configuration:

First I am going to troubleshoot Router0:

Router#show ip protocols
Routing Protocol is “rip”
Sending updates every 30 seconds, next due in 13 seconds
Invalid after 180 seconds, hold down 180, flushed after 240
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Redistributing: rip
Default version control: send version 2, receive 2
Interface Send Recv Triggered RIP Key-chain
Serial0/0/1 2 2
Serial0/0/0 2 2
Automatic network summarization is in effect
Maximum path: 4
Routing for Networks:
40.0.0.0
50.0.0.0
Passive Interface(s):
Routing Information Sources:
Gateway Distance Last Update
40.0.0.1 120 00:00:23
50.0.0.1 120 00:00:07
Distance: (default is 120)

 

Router#show ip route
Codes: C – connected, S – static, I – IGRP, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2, E – EGP
i – IS-IS, L1 – IS-IS level-1, L2 – IS-IS level-2, ia – IS-IS inter area
* – candidate default, U – per-user static route, o – ODR
P – periodic downloaded static route

Gateway of last resort is not set

R 10.0.0.0/8 [120/2] via 40.0.0.1, 00:00:00, Serial0/0/0
[120/2] via 50.0.0.1, 00:00:17, Serial0/0/1
R 20.0.0.0/8 [120/1] via 40.0.0.1, 00:00:00, Serial0/0/0
R 30.0.0.0/8 [120/1] via 40.0.0.1, 00:00:00, Serial0/0/0
C 40.0.0.0/8 is directly connected, Serial0/0/0
C 50.0.0.0/8 is directly connected, Serial0/0/1
R 60.0.0.0/8 [120/2] via 40.0.0.1, 00:00:00, Serial0/0/0
[120/2] via 50.0.0.1, 00:00:17, Serial0/0/1
R 70.0.0.0/8 [120/2] via 50.0.0.1, 00:00:17, Serial0/0/1
[120/2] via 40.0.0.1, 00:00:00, Serial0/0/0
R 80.0.0.0/8 [120/1] via 50.0.0.1, 00:00:17, Serial0/0/1
R 90.0.0.0/8 [120/2] via 50.0.0.1, 00:00:17, Serial0/0/1
[120/2] via 40.0.0.1, 00:00:00, Serial0/0/0
R 100.0.0.0/8 [120/1] via 50.0.0.1, 00:00:17, Serial0/0/1
R 110.0.0.0/8 [120/1] via 50.0.0.1, 00:00:17, Serial0/0/1
[120/1] via 40.0.0.1, 00:00:00, Serial0/0/0

 

Router#show protocols
Global values:
Internet Protocol routing is enabled
FastEthernet0/0 is administratively down, line protocol is down
FastEthernet0/1 is administratively down, line protocol is down
Serial0/0/0 is up, line protocol is up
Internet address is 40.0.0.2/8
Serial0/0/1 is up, line protocol is up
Internet address is 50.0.0.2/8
Vlan1 is administratively down, line protocol is down

Leave a Reply

Please log in using one of these methods to post your comment:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s