redistribution configuration lab between two eigrp autonomous system using cisco packet tracer

Posted: 22 Apr 2018 in CCNA
Tags: ,

This article is all about redistribution configuration lab between two eigrp autonomous system . Here in this lab we will configure  EIGRP  having different autonomous number. To show Multiple EIGRP AS configuration on same router i am using cisco packet tracer. You can see EIGRP neighbors with different AS numbers in this lab and you will learn how to configure it to communicate them.In below topology diagram you can see EIGRP Topology having different Autonomous Value. There are total three routers R1, R2 and R3 R1 is in As 1 while R3 in AS 2. But R2 is in both AS.Now read carefully how i am going to configure it.

eigrp with multiple AS

Step 1:Assign IP Address on Router R1:

 

Router>enable

Router#config t

Router(config)#host R1

R1(config)#int fa0/1

R1(config-if)#ip add 1.0.0.1 255.0.0.0

R1(config-if)#no shut

R1(config-if)#exit

R1(config)#int fa0/0

R1(config-if)#ip add 2.0.0.1 255.0.0.0

R1(config-if)#no shut

 

Step 2:Assign IP Address on Router R2:

Router>enable

Router#config t

Router(config)#host r2

r2(config)#host R2

R2(config)#int fa0/0

R2(config-if)#ip add 2.0.0.2 255.0.0.0

R2(config-if)#no shut

R2(config-if)#exit

R2(config)#int fa0/1

R2(config-if)#ip add 3.0.0.1 255.0.0.0

R2(config-if)#no shut

 

Step 3:Assign IP Address on Router R3:

Router>enable

Router#config t

R3(config)#int fa0/0

R3(config-if)#ip add 3.0.0.2 255.0.0.0

R3(config-if)#no shut

R3(config-if)#exit

R3(config)#int fa0/1

R3(config-if)#ip add 4.0.0.1 255.0.0.0

R3(config-if)#no shut

 

Step 4:EIGRP configuration on Router R1:

R1(config)#router eigrp 1

R1(config-router)#network 1.0.0.0

R1(config-router)#network 2.0.0.0

R1(config-router)#exit

 

Step 5:EIGRP configuration on Router R2:

R2(config)#router eigrp 1

R2(config-router)#network 2.0.0.0

R2(config-router)#exit

R2(config)#router eigrp 2

R2(config-router)#network 3.0.0.0

R2(config-router)#exit

 

Step 6: EIGRP configuration on Router R3:

R3(config)#router eigrp 2

R3(config-router)#network 3.0.0.0

R3(config-router)#network 4.0.0.0

 

 

Step 7:Redistribute EIGRP  Autonomous system 1 in to EIGRP Autonomous System 2

R2(config)#router eigrp 1

R2(config-router)#redistribute eigrp 2

R2(config-router)#exit

Step 8:Redistribute EIGRP  Autonomous system 2 in to EIGRP Autonomous System 1

R2(config)#router eigrp 2

R2(config-router)#redistribute eigrp 1

R2(config-router)#exit

R2(config)#do write

Building configuration...

[OK]

R2(config)#

 

Step 10: EIGRP Verification and Troubleshooting

I am on PC0 and now I am going to check IP address of PC0 using ipconfig command.

 

PC>ipconfig

FastEthernet0 Connection:(default port)

Link-local IPv6 Address.........: FE80::230:F2FF:FEC1:5B11

IP Address......................: 1.0.0.2

Subnet Mask.....................: 255.0.0.0

Default Gateway.................: 1.0.0.1

 

Now Test network communication using ping command.

 

PC>ping 4.0.0.2

Pinging 4.0.0.2 with 32 bytes of data:

Reply from 4.0.0.2: bytes=32 time=0ms TTL=125

Reply from 4.0.0.2: bytes=32 time=0ms TTL=125

Reply from 4.0.0.2: bytes=32 time=0ms TTL=125

Reply from 4.0.0.2: bytes=32 time=1ms TTL=125

Ping statistics for 4.0.0.2:

Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),

Approximate round trip times in milli-seconds:

Minimum = 0ms, Maximum = 1ms, Average = 0ms

PC>

 

Step 11:Check and Verify EIGRP Traffic

eigrp traffic

Step 12:Check and Verify EIGRP Topology

eigrp topology

Step 13:Check and Verify EIGRP Neighbors

eigrp neighbors

Step 14:Check and verify EIGRP INTERFACES having Different AS(Autonomous System)
R2#show ip eigrp interfaces

IP-EIGRP interfaces for process 1

Xmit Queue Mean Pacing Time Multicast Pending

Interface Peers Un/Reliable SRTT Un/Reliable Flow Timer Routes

Fa0/0 1 0/0 1236 0/10 0 0

IP-EIGRP interfaces for process 2

Xmit Queue Mean Pacing Time Multicast Pending

Interface Peers Un/Reliable SRTT Un/Reliable Flow Timer Routes

Fa0/1 1 0/0 1236 0/10 0 0

R2#

eigrp interfaces

Step 15:Check and Verify Routing Protocol
R2#show ip protocols

Routing Protocol is "eigrp 1 "

Outgoing update filter list for all interfaces is not set

Incoming update filter list for all interfaces is not set

Default networks flagged in outgoing updates

Default networks accepted from incoming updates

EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0

EIGRP maximum hopcount 100

EIGRP maximum metric variance 1

Redistributing: eigrp 1,

Automatic network summarization is in effect

Automatic address summarization:

Maximum path: 4

Routing for Networks:

2.0.0.0

Routing Information Sources:

Gateway Distance Last Update

2.0.0.1 90 1282082

Distance: internal 90 external 170

Routing Protocol is "eigrp 2 "

Outgoing update filter list for all interfaces is not set

Incoming update filter list for all interfaces is not set

Default networks flagged in outgoing updates

Default networks accepted from incoming updates

EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0

EIGRP maximum hopcount 100

EIGRP maximum metric variance 1

Redistributing: eigrp 2,

Automatic network summarization is in effect

Automatic address summarization:

Maximum path: 4

Routing for Networks:

3.0.0.0

Routing Information Sources:

Gateway Distance Last Update

3.0.0.2 90 1358909

Distance: internal 90 external 170

 

Step 16: Check and Verify EIGRP Routing Tables
R2#show ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

* - candidate default, U - per-user static route, o - ODR

P - periodic downloaded static route

Gateway of last resort is not set

D 1.0.0.0/8 [90/30720] via 2.0.0.1, 00:04:08, FastEthernet0/0

C 2.0.0.0/8 is directly connected, FastEthernet0/0

C 3.0.0.0/8 is directly connected, FastEthernet0/1

D 4.0.0.0/8 [90/30720] via 3.0.0.2, 00:02:36, FastEthernet0/1

 

Advertisements
Comments
  1. Loopy says:

    For two way Redistribution, you actually need to set tagging on your redistribute statements, otherwise “Route leaking” can occur where Routes are shared back across the network that are already known.

    An example of such a Route-Map:

    R1#conf t
    Enter configuration commands, one per line. End with CNTL/Z.
    R1(config)#route-map EIGRP2OSPF permit 10 <—– Sequence # 10 in Route-Map
    R1(config-route-map)#set tag 100
    R1(config-route-map)#exit
    R1(config)#route-map OSPF2EIGRP deny 10 <—– Sequence # 10 in Route-Map
    R1(config-route-map)#match tag 100
    R1(config-route-map)#route-map OSPF2EIGRP permit 20

    The actual Route-Map itself:

    R1#sh route-map
    route-map EIGRP2OSPF, permit, sequence 10
    Match clauses:
    Set clauses:
    tag 100
    Policy routing matches: 0 packets, 0 bytes
    route-map OSPF2EIGRP, deny, sequence 10
    Match clauses:
    tag 100
    Set clauses:
    Policy routing matches: 0 packets, 0 bytes
    route-map OSPF2EIGRP, permit, sequence 20
    Match clauses:
    Set clauses:
    Policy routing matches: 0 packets, 0 bytes
    R1#

    So R1 EIGRP routes going into the OSPF Domain are tagged as 100, and OSPF routes going into the EIGRP Domain are going to Deny any routes tagged as 100, and allow the rest through.

    The bottom Route-Map Sequence # 20 is a "Catch All" Clause saying "All other traffic route normally" and has no tagging / actions configured to be taken.

    Just to be clear about Route Redistribution, unless you are doing it one way, tagging / route-maps or a similar mechanism for tagging routes must be used 🙂

    Like

Leave a Reply

Please log in using one of these methods to post your comment:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google+ photo

You are commenting using your Google+ account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s

This site uses Akismet to reduce spam. Learn how your comment data is processed.