PAP(Password Authentical Protocol) Configuration on cisco router

Posted: July 21, 2015 in CCNA
Tags: , , , ,

In this tutorial you will learn how to configure PPP(Point to Point Protocol).

Authentication— You can use authentication to verify a router’s identity when it is connecting into your router. Options for authentication include CHAP and PAP.

Here in this lab we will learn how to configure  PAP between two routers using cisco packet tracer.

PAP is an authentication method that can be used over Point to Point links. The username and password are sent in plain text, there is no encryption or protection. If it is accepted, the connection is allowed.Password Authentication Protocol goes through two way handshake process but still it  is not considered a strong authentication protocol. 

pap configuration lab

 

Configuration on Router R1:

 

Router>enable

Router#config terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#hostname R1

R1(config)#int fa0/0

R1(config-if)#ip address 1.0.0.1 255.0.0.0

R1(config-if)#no shut

 

R1(config-if)#exit

R1(config)#interface se0/0/0

R1(config-if)#ip address 2.0.0.1 255.0.0.0

R1(config-if)#clock rate 64000

R1(config-if)#no shut

 

Bydefault HDLC is configured on router interface,If you want to confirm you can use below command.

 

R1#show interface se0/0/0

Serial0/0/0 is up, line protocol is up (connected)

Hardware is HD64570

Internet address is 2.0.0.1/8

MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation HDLC, loopback not set, keepalive set (10 sec)

 

PPP Configuration on Router R1:

 

R1#config t

Enter configuration commands, one per line. End with CNTL/Z.

R1(config)#username R2 password ccna123

R1(config)#int se0/0/0

R1(config-if)#encapsulation ppp

R1(config-if)#ppp authentication pap

R1(config-if)#ppp pap sent-username R1 password ccna123

 

Verify whether PPP is configured or not on your router serial interface using below command.

 

R1#show interface se0/0/0

Serial0/0/0 is up, line protocol is down (disabled)

Hardware is HD64570

Internet address is 2.0.0.1/8

MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation PPP, loopback not set, keepalive set (10 sec)

 

 

Configuration on Router  R2:

 

Router>enable

Router#config t

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#hostname R2

R2(config)#int fa0/0

R2(config-if)#ip address 3.0.0.1 255.0.0.0

R2(config-if)#no shut

 

R2(config-if)#exit

R2(config)#int se0/0/0

R2(config-if)#ip address 2.0.0.2 255.0.0.0

R2(config-if)#no shut

 

See router interface before configuring PPP over it.

 

R2#show interface se0/0/0

Serial0/0/0 is up, line protocol is up (connected)

Hardware is HD64570

Internet address is 2.0.0.2/8

MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation HDLC, loopback not set, keepalive set (10 sec)

 

PPP Configuration over Router R2:

 

R2#config t

Enter configuration commands, one per line. End with CNTL/Z.

R2(config)#username R1 password ccna123

R2(config)#int se0/0/0

R2(config-if)#encapsulation ppp

R2(config-if)#ppp authentication pap

R2(config-if)#ppp pap sent-username R2 password ccna123

 

Verify Router serial interface after configuring PPP over it.

 

R2#show int se0/0/0

Serial0/0/0 is up, line protocol is up (connected)

Hardware is HD64570

Internet address is 2.0.0.2/8

MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation PPP, loopback not set, keepalive set (10 sec)

 

Connection Testing  using ping after Configuration of PAP between routers:

R1(config)#do ping 2.0.0.2

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 2.0.0.2, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/17/37 ms

 

Connection Testing  using ping command after Configuration of PAP between routers:

R2(config)#do ping 2.0.0.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 2.0.0.1, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/7/21 ms

R2(config)#

Leave a Reply

Please log in using one of these methods to post your comment:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s