InterVLAN Routing Configuration Lab using cisco packet tracer

Posted: July 25, 2017 in CCNA
Tags: , ,
Today in this tutorial i am going to show you how to configure InterVLAN Routing. But before that we need to know what is InterVLAN Routing and Why we use it? What is the benefits of using intervlan routing?
InterVLAN Routing allow hosts and PCs in different vlan to communicate with each other. As we all know machines or PC in same VLAN can communicate with each other but if you want machines from other VLAN to communicate with you, for that you need to configure InterVLAN Routing.So here in this tutorial i will explain step wise method to easily configure InterVLAN Routing.

InterVLAN Routing Configuration

STEP 1: Take four PC ,One Switch and A Router and connect them As i have shown in above topology Image.

 

STEP 2: Assign IP Address to ALL Computers.

 

1.0.0.2    and  1.0.0.3   to PC0  and  PC1

2.0.0.2   and  2.0.0.3  to PC2 and   PC3

 

STEP 3: Configure VLAN,Assign switch Ports to VLAN and Set Ports to access Mode.

 

 

Switch>enable

Switch#config t

Enter configuration commands, one per line. End with CNTL/Z.

Switch(config)#vlan 10

Switch(config-vlan)#exit

Switch(config)#vlan 20

Switch(config-vlan)#exit

Switch(config)#int range fa0/1-2

Switch(config-if-range)#switchport mode access

Switch(config-if-range)#switchport access vlan 10

Switch(config-if-range)#exit

Switch(config)#int range fa0/3-4

Switch(config-if-range)#switchport mode access

Switch(config-if-range)#switchport access vlan 20

 

STEP 4: Create TRUNK PORT on SWITCH PORT which connected with ROUTER.

Since here in this Lab interface Fa0/5 port of switch is connected with Router and this port will have to route both VLAN network so we have to create TRUNK PORT on this Interface.

 

 

Switch(config)#int fa0/5

Switch(config-if)#no shut

Switch(config-if)#switchport mode trunk
STEP 5:GO  To Router interface Fa0/0 and turned ON interface.
Router(config)#int fa0/0

Router(config-if)#no shut

 

 

 

STEP 6:Create sub-interfaces, set 802.1Q trunking protocol and ip address on each sub-interface

 

 

Router(config)#int fa0/0.1

Router(config-subif)#encapsulation dot1q 10

Router(config-subif)#ip address 1.0.0.1 255.0.0.0

Router(config-subif)#no shut

Router(config-subif)#exit

Router(config)#int fa0/0.2



Router(config-subif)#encapsulation dot1q 20

Router(config-subif)#ip address 2.0.0.1 255.0.0.0

Router(config-subif)#no shut

Router(config-subif)#

 

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s