OSPF CONFIGURATION LAB:Learn to configure ospf in a complex network

Posted: April 26, 2015 in CCNA
Tags: , , ,

In this article we will learn how to configure ospf routing protocol  in a complex network.OSPF(Open Shortes Path First) Routing can be done on any router it is not a cisco proprietary.Since it is an open standard it will run on most of routers.OSPF uses SPF algorithm to provide a loop free topology.OSPF is also a classless protocol.OSPF is complex to configure and troubleshoot.Here we will learn ospf routing protocol configuration through an example lab.I am going to Create a topology.See below to design topology diagram in your cisco packet tracer.

OSPF routing Protocol configuration is slightly different from EIGRP and RIP.

Router(config)# router ospf process_ID
Router(config-router)# network IP_address wildcard_mask area area_value

ospf configuration

Before configuring OSPF routing protocols on each routers,we need to assign ip address to each and every interface of routers,up the network,set clock rate on all DCE interface.

 

START CONFIGURING IP ADDRESS ON EACH  ROUTERS STEP WISE: 

 

— System Configuration Dialog —

Continue with configuration dialog? [yes/no]: no
Press RETURN to get started!
Router>enable
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname R1
R1(config)#int fa0/1
R1(config-if)#ip address 211.146.0.1 255.255.255.0
R1(config-if)#no shut
R1(config-if)#exit
R1(config)#int fa0/0
R1(config-if)#ip address 211.146.1.1 255.255.255.0
R1(config-if)#no shut



 --- System Configuration Dialog ---
Continue with configuration dialog? [yes/no]: no
Press RETURN to get started!
Router>enable
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname R2
R2(config)#int fa0/0
R2(config-if)#ip address 211.146.1.2 255.255.255.0
R2(config-if)#no shut
R2(config-if)#exit
R2(config)#int se0/0/0
R2(config-if)#ip address 211.146.2.1 255.255.255.0
R2(config-if)#clock rate 64000
R2(config-if)#no shut



 --- System Configuration Dialog ---
Continue with configuration dialog? [yes/no]: no
Press RETURN to get started!
Router>enable
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname R3
R3(config)#int se0/0/0
R3(config-if)#ip address 211.146.2.2 255.255.255.0
R3(config-if)#no shut
R3(config-if)#exit
R3(config)#int se0/0/1
R3(config-if)#ip address 211.146.3.1 255.255.255.0
R3(config-if)#clock rate 64000
R3(config-if)#no shut
R3(config-if)#exit
R3(config)#int fa0/0
R3(config-if)#ip address 211.146.5.1 255.255.255.0
R3(config-if)#no shut




 --- System Configuration Dialog ---
Continue with configuration dialog? [yes/no]: no
Press RETURN to get started!
Router>enable
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname R4
R4(config)#int eth0/0/0
R4(config-if)#ip address 211.146.5.2 255.255.255.0
R4(config-if)#no shut
R4(config-if)#exit
R4(config)#int fa0/1 
R4(config-if)#ip address 211.146.6.1 255.255.255.0
R4(config-if)#no shut



--- System Configuration Dialog ---
Continue with configuration dialog? [yes/no]: no
Press RETURN to get started!
Router>enable
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname R5
R5(config)#int fa0/0
R5(config-if)#ip address 211.146.6.2 255.255.255.0
R5(config-if)#no shut
R5(config-if)#exit
R5(config)#int eth0/0/0 
R5(config-if)#ip address 211.146.7.2 255.255.255.0
R5(config-if)#no shut



--- System Configuration Dialog ---
Continue with configuration dialog? [yes/no]: no
Press RETURN to get started!
Router>enable
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname R6
R6(config)#int se0/0/0
R6(config-if)#ip address 211.146.3.2 255.255.255.0
R6(config-if)#no shut
R6(config-if)#exit
R6(config)#int se0/0/1
R6(config-if)#ip address 211.146.4.1 255.255.255.0
R6(config-if)#clock rate 64000
R6(config-if)#no shut
R6(config-if)#exit
R6(config)#int fa0/0
R6(config-if)#ip address 211.146.7.1 255.255.255.0
R6(config-if)#no shut



--- System Configuration Dialog ---
Continue with configuration dialog? [yes/no]: no
Press RETURN to get started!
Router>enable
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname R7
R7(config)#int se0/0/0 
R7(config-if)#ip address 211.146.4.2 255.255.255.0
R7(config-if)#no shut
R7(config-if)#exit
R7(config)#int fa0/0
R7(config-if)#ip address 211.146.8.1 255.255.255.0
R7(config-if)#no shut



--- System Configuration Dialog ---
Continue with configuration dialog? [yes/no]: no
Press RETURN to get started!
Router>enable
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname R8
R8(config)#int fa0/0
R8(config-if)#ip address 211.146.8.2 255.255.255.0
R8(config-if)#no shut
R8(config-if)#exit
R8(config)#int fa0/1
R8(config-if)#ip address 211.146.9.1 255.255.255.0
R8(config-if)#no shut



 Configure and Enable OSPF Routing Protocol on ROUTER R1:
R1(config)#router ospf 1
R1(config-router)#network 211.146.0.0 0.0.0.255 area 0
R1(config-router)#network 211.146.1.0 0.0.0.255 area 0
R1(config-router)#exit

 Configure and Enable OSPF Routing Protocol on ROUTER R2:
R2(config)#router ospf 2
R2(config-router)#network 211.146.1.0 0.0.0.255 area 0
23:07:45: %OSPF-5-ADJCHG: Process 2, Nbr 211.146.1.1 on FastEthernet0/0 from LOADING to FULL, Loading Done
R2(config-router)#network 211.146.2.0 0.0.0.255 area 0
R2(config-router)#exit

 Configure and Enable OSPF Routing Protocol on ROUTER R3:
R3(config)#router ospf 3
R3(config-router)#network 211.146.2.0 0.0.0.255 area 0
R3(config-router)#
23:08:38: %OSPF-5-ADJCHG: Process 3, Nbr 211.146.2.1 on Serial0/0/0 from LOADING to FULL, Loading Done
R3(config-router)#network 211.146.3.0 0.0.0.255 area 0
R3(config-router)#network 211.146.5.0 0.0.0.255 area 0
R3(config-router)#exit

 Configure and Enable OSPF Routing Protocol on ROUTER R4:
R4(config)#router ospf 4
R4(config-router)#network 211.146.5.0 0.0.0.255 area 0
R4(config-router)#
23:12:08: %OSPF-5-ADJCHG: Process 4, Nbr 211.146.5.1 on Ethernet0/0/0 from LOADING to FULL, Loading Done
R4(config-router)#network 211.146.6.0 0.0.0.255 area 0
R4(config-router)#exit

 Configure and Enable OSPF Routing Protocol on ROUTER R5:
R5(config)#router ospf 5
R5(config-router)#network 211.146.6.0 0.0.0.255 area 0
R5(config-router)#
23:13:30: %OSPF-5-ADJCHG: Process 5, Nbr 211.146.6.1 on FastEthernet0/0 from LOADING to FULL, Loading Done
R5(config-router)#network 211.146.7.0 0.0.0.255 area 0
R5(config-router)#exit

 Configure and Enable OSPF Routing Protocol on ROUTER R6:
R6(config)#router ospf 6
R6(config-router)#network 211.146.3.0 0.0.0.255 area 0
R6(config-router)#
23:15:37: %OSPF-5-ADJCHG: Process 6, Nbr 211.146.5.1 on Serial0/0/0 from LOADING to FULL, Loading Done
R6(config-router)#network 211.146.7.0 0.0.0.255 area 0
R6(config-router)#
23:16:00: %OSPF-5-ADJCHG: Process 6, Nbr 211.146.7.2 on FastEthernet0/0 from LOADING to FULL, Loading Done
R6(config-router)#network 211.146.4.0 0.0.0.255 area 0
R6(config-router)#exit

 Configure and Enable OSPF Routing Protocol on ROUTER R7:
R7(config)#router ospf 7
R7(config-router)#network 211.146.4.0 0.0.0.255 area 0
R7(config-router)#
23:21:54: %OSPF-5-ADJCHG: Process 7, Nbr 211.146.7.1 on Serial0/0/0 from LOADING to FULL, Loading Done
R7(config-router)#network 211.146.8.0 0.0.0.255 area 0
R7(config-router)#exit

 Configure and Enable OSPF Routing Protocol on ROUTER R8:
R8(config)#router ospf 8
R8(config-router)#network 211.146.8.0 0.0.0.255 area 0
R8(config-router)#
23:25:51: %OSPF-5-ADJCHG: Process 8, Nbr 211.146.8.1 on FastEthernet0/0 from LOADING to FULL, Loading Done
R8(config-router)#network 211.146.9.0 0.0.0.255 area 0
R8(config-router)#exit
Comments
  1. […] article we will learn to troubleshoot OSPF routing protocols.In previous article we have learnt how to configure ospf routing protocol.And now in this section we will learn how to troubleshoot ospf routing protocol and to do so we […]

    Like

  2. […] article we will learn to troubleshoot OSPF routing protocols.In previous article we have learnt how to configure ospf routing protocol.And now in this section we will learn how to troubleshoot ospf routing protocol and to do so we […]

    Like

Leave a Reply

Please log in using one of these methods to post your comment:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s