EIGRP CONFIGURATION ON CISCO ROUTERS:A COMPLEX LAB SHOWING EIGRP CONFIGURATION IN A COMPLEX NETWORK USING CSCO PACKET TRACER.

Today in this tutorial we learn how to configure a EIGRP on a cisco router.If you are a CCNA student then i hope you very well know how to configure it and you have configured EIGRP in cisco packet tracer so many times.But here in this article i will show you how to configure EIGRP on cisco routers for a complex network.

complex eigrp configuration

CONFIGURATION ON ROUTER R1: 

— System Configuration Dialog —

Continue with configuration dialog? [yes/no]: no
Press RETURN to get started!

Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname R1
R1(config)#int fa0/0
R1(config-if)#ip address 172.70.0.1 255.255.0.0
R1(config-if)#no shut
R1(config-if)#exit
R1(config)#int se0/0/0
R1(config-if)#ip address 172.71.0.1 255.255.0.0
R1(config-if)#clock rate 64000
R1(config-if)#no shut
R1(config-if)#exit
R1(config)#int se0/1/0
R1(config-if)#ip address 172.72.0.1 255.255.0.0
R1(config-if)#clock rate 64000
R1(config-if)#no shut
R1(config-if)#exit
R1(config)#int se0/0/1
R1(config-if)#ip address 172.73.0.1 255.255.0.0
R1(config-if)#clock rate 64000
R1(config-if)#no shut

 

CONFIGURATION ON ROUTER R2:
— System Configuration Dialog —

Continue with configuration dialog? [yes/no]: no
Press RETURN to get started!

Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname R2
R2(config)#int se0/0/0
R2(config-if)#ip address 172.71.0.2 255.255.0.0
R2(config-if)#no shut
R2(config-if)#exit
R2(config)#int se0/0/1
R2(config-if)#ip address 172.78.0.1 255.255.0.0
R2(config-if)#clock rate 64000
R2(config-if)#no shut
R2(config-if)#exit
R2(config)#int se0/1/0
R2(config-if)#ip address 172.77.0.1 255.255.0.0
R2(config-if)#clock rate 64000
R2(config-if)#no shut

 

CONFIGURATION ON ROUTER R3:
— System Configuration Dialog —

Continue with configuration dialog? [yes/no]: no
Press RETURN to get started!

Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname R3
R3(config)#int se0/0/1
R3(config-if)#ip address 172.78.0.2 255.255.0.0
R3(config-if)#no shut
R3(config-if)#exit
R3(config)#int se0/1/0
R3(config-if)#ip address 172.72.0.2 255.255.0.0
R3(config-if)#no shut
R3(config-if)#exit
R3(config)#int se0/0/0
R3(config-if)#ip address 172.74.0.2 255.255.0.0
R3(config-if)#no shut
R3(config-if)#exit
R3(config)#int se0/1/1
R3(config-if)#ip address 172.76.0.1 255.255.0.0
R3(config-if)#clock rate 64000
R3(config-if)#no shut

 

CONFIGURATION ON ROUTER R4:

— System Configuration Dialog —

Continue with configuration dialog? [yes/no]: no
Press RETURN to get started!

Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname R4
R4(config)#int se0/0/1
R4(config-if)#ip address 172.74.0.1 255.255.0.0
R4(config-if)#clock rate 64000
R4(config-if)#no shut
R4(config-if)#exit
R4(config)#int se0/0/0
R4(config-if)#ip address 172.73.0.2 255.255.0.0
R4(config-if)#no shut
R4(config-if)#exit
R4(config)#int se0/1/0
R4(config-if)#ip address 172.75.0.1 255.255.0.0
R4(config-if)#clock rate 64000
R4(config-if)#no shut

 

CONFIGURATION ON ROUTER R5:

— System Configuration Dialog —

Continue with configuration dialog? [yes/no]: no
Press RETURN to get started!

Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname R5
R5(config)#int fa0/0
R5(config-if)#ip address 172.79.0.1 255.255.0.0
R5(config-if)#no shut
R5(config-if)#exit
R5(config)#int se0/0/1
R5(config-if)#ip address 172.77.0.2 255.255.0.0
R5(config-if)#no shut
R5(config-if)#exit
R5(config)#int se0/1/0
R5(config-if)#ip address 172.76.0.2 255.255.0.0
R5(config-if)#no shut
R5(config-if)#exit
R5(config)#int se0/0/0
R5(config-if)#ip address 172.75.0.2 255.255.0.0
R5(config-if)#no shut

 

CONFIGURING EIGRP ON ROUTER R1 R2 R3 R4 and R5:

We will Turn on the EIGRP process and assign the autonoumous system.

Here in this LAB we have taken 1 as the Autonomous System (AS) number. It can be from 1 to 65535.

Note:All routers in the same network must use the same AS number.
R1(config)#router eigrp 1
R1(config-router)#network 172.70.0.0
R1(config-router)#network 172.71.0.0
R1(config-router)#network 172.72.0.0
R1(config-router)#network 172.73.0.0
R1(config-router)#exit

 

R2(config)#router eigrp 1
R2(config-router)#network 172.71.0.0
R2(config-router)#network 172.77.0.0
R2(config-router)#network 172.78.0.0

 

R3(config)#router eigrp 1
R3(config-router)#network 172.72.0.0
R3(config-router)#network 172.74.0.0
R3(config-router)#network 172.76.0.0
R3(config-router)#network 172.78.0.0

R3(config-router)#exit

 

R4(config)#router eigrp 1
R4(config-router)#network 172.73.0.0

R4(config-router)#network 172.74.0.0

R4(config-router)#network 172.75.0.0
R4(config-router)#exit

R5(config)#router eigrp 1
R5(config-router)#network 172.75.0.0

R5(config-router)#network 172.76.0.0

R5(config-router)#network 172.77.0.0

R5(config-router)#network 172.79.0.0
R5(config-router)#exit

 

EIGRP TROUBLESHOOTING COMMAND:

After configuring eigrp if you face any problem in communicating your devices you can use below troubleshooting command to find the fault in your network and then fix them.

R1>show ip route
Codes: C – connected, S – static, I – IGRP, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2, E – EGP
i – IS-IS, L1 – IS-IS level-1, L2 – IS-IS level-2, ia – IS-IS inter area
* – candidate default, U – per-user static route, o – ODR
P – periodic downloaded static route

Gateway of last resort is not set

C 172.70.0.0/16 is directly connected, FastEthernet0/0
C 172.71.0.0/16 is directly connected, Serial0/0/0
C 172.72.0.0/16 is directly connected, Serial0/1/0
C 172.73.0.0/16 is directly connected, Serial0/0/1
D 172.74.0.0/16 [90/2681856] via 172.73.0.2, 00:07:48, Serial0/0/1
[90/2681856] via 172.72.0.2, 00:07:47, Serial0/1/0
D 172.75.0.0/16 [90/2681856] via 172.73.0.2, 00:07:48, Serial0/0/1
D 172.76.0.0/16 [90/2681856] via 172.72.0.2, 00:07:47, Serial0/1/0
D 172.77.0.0/16 [90/2681856] via 172.71.0.2, 00:07:50, Serial0/0/0
D 172.78.0.0/16 [90/2681856] via 172.71.0.2, 00:07:50, Serial0/0/0
[90/2681856] via 172.72.0.2, 00:07:47, Serial0/1/0
D 172.79.0.0/16 [90/2684416] via 172.71.0.2, 00:07:50, Serial0/0/0
[90/2684416] via 172.73.0.2, 00:07:47, Serial0/0/1
[90/2684416] via 172.72.0.2, 00:07:47, Serial0/1/0

 

R1>show ip route eigrp
D 172.74.0.0/16 [90/2681856] via 172.73.0.2, 00:09:40, Serial0/0/1
[90/2681856] via 172.72.0.2, 00:09:39, Serial0/1/0
D 172.75.0.0/16 [90/2681856] via 172.73.0.2, 00:09:40, Serial0/0/1
D 172.76.0.0/16 [90/2681856] via 172.72.0.2, 00:09:39, Serial0/1/0
D 172.77.0.0/16 [90/2681856] via 172.71.0.2, 00:09:42, Serial0/0/0
D 172.78.0.0/16 [90/2681856] via 172.71.0.2, 00:09:42, Serial0/0/0
[90/2681856] via 172.72.0.2, 00:09:39, Serial0/1/0
D 172.79.0.0/16 [90/2684416] via 172.71.0.2, 00:09:42, Serial0/0/0
[90/2684416] via 172.73.0.2, 00:09:39, Serial0/0/1
[90/2684416] via 172.72.0.2, 00:09:39, Serial0/1/0

 

R1>show ip protocols

Routing Protocol is “eigrp 1 ”
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Default networks flagged in outgoing updates
Default networks accepted from incoming updates
EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0
EIGRP maximum hopcount 100
EIGRP maximum metric variance 1
Redistributing: eigrp 1
Automatic network summarization is in effect
Automatic address summarization:
Maximum path: 4
Routing for Networks:
172.70.0.0
172.71.0.0
172.72.0.0
172.73.0.0
Routing Information Sources:
Gateway Distance Last Update
172.71.0.2 90 6254
172.73.0.2 90 7948
172.72.0.2 90 8534
Distance: internal 90 external 170

 

R1>show ip eigrp traffic
IP-EIGRP Traffic Statistics for process 1
Hellos sent/received: 611/453
Updates sent/received: 16/20
Queries sent/received: 0/0
Replies sent/received: 0/0
Acks sent/received: 20/16
Input queue high water mark 1, 0 drops
SIA-Queries sent/received: 0/0
SIA-Replies sent/received: 0/0

 

R1>show ip eigrp traffic 1
IP-EIGRP Traffic Statistics for process 1
Hellos sent/received: 634/470
Updates sent/received: 16/20
Queries sent/received: 0/0
Replies sent/received: 0/0
Acks sent/received: 20/16
Input queue high water mark 1, 0 drops
SIA-Queries sent/received: 0/0
SIA-Replies sent/received: 0/0

 

R1>show ip eigrp topology
IP-EIGRP Topology Table for AS 1

Codes: P – Passive, A – Active, U – Update, Q – Query, R – Reply,
r – Reply status

P 172.70.0.0/16, 1 successors, FD is 28160
via Connected, FastEthernet0/0
P 172.72.0.0/16, 1 successors, FD is 2169856
via Connected, Serial0/1/0
P 172.71.0.0/16, 1 successors, FD is 2169856
via Connected, Serial0/0/0
P 172.73.0.0/16, 1 successors, FD is 2169856
via Connected, Serial0/0/1
P 172.77.0.0/16, 1 successors, FD is 2681856
via 172.71.0.2 (2681856/2169856), Serial0/0/0
P 172.78.0.0/16, 2 successors, FD is 2681856
via 172.71.0.2 (2681856/2169856), Serial0/0/0
via 172.72.0.2 (2681856/2169856), Serial0/1/0
P 172.79.0.0/16, 3 successors, FD is 2684416
via 172.71.0.2 (2684416/2172416), Serial0/0/0
via 172.73.0.2 (2684416/2172416), Serial0/0/1
via 172.72.0.2 (2684416/2172416), Serial0/1/0
P 172.76.0.0/16, 1 successors, FD is 2681856
via 172.72.0.2 (2681856/2169856), Serial0/1/0
P 172.74.0.0/16, 2 successors, FD is 2681856
via 172.73.0.2 (2681856/2169856), Serial0/0/1
via 172.72.0.2 (2681856/2169856), Serial0/1/0
P 172.75.0.0/16, 1 successors, FD is 2681856
via 172.73.0.2 (2681856/2169856), Serial0/0/1

 

R1>show ip eigrp nei
IP-EIGRP neighbors for process 1
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
0 172.71.0.2 Se0/0/0 12 00:13:24 40 1000 0 20
1 172.73.0.2 Se0/0/1 10 00:13:22 40 1000 0 32
2 172.72.0.2 Se0/1/0 14 00:13:22 40 1000 0 28

 

R1>show ip eigrp topology all-links
IP-EIGRP Topology Table for AS 1

Codes: P – Passive, A – Active, U – Update, Q – Query, R – Reply,
r – Reply status

P 172.70.0.0/16, 1 successors, FD is 28160
via Connected, FastEthernet0/0
P 172.72.0.0/16, 1 successors, FD is 2169856
via Connected, Serial0/1/0
P 172.71.0.0/16, 1 successors, FD is 2169856
via Connected, Serial0/0/0
P 172.73.0.0/16, 1 successors, FD is 2169856
via Connected, Serial0/0/1
P 172.77.0.0/16, 1 successors, FD is 2681856
via 172.71.0.2 (2681856/2169856), Serial0/0/0
P 172.78.0.0/16, 2 successors, FD is 2681856
via 172.71.0.2 (2681856/2169856), Serial0/0/0
via 172.72.0.2 (2681856/2169856), Serial0/1/0
P 172.79.0.0/16, 3 successors, FD is 2684416
via 172.71.0.2 (2684416/2172416), Serial0/0/0
via 172.73.0.2 (2684416/2172416), Serial0/0/1
via 172.72.0.2 (2684416/2172416), Serial0/1/0
P 172.76.0.0/16, 1 successors, FD is 2681856
via 172.72.0.2 (2681856/2169856), Serial0/1/0
P 172.74.0.0/16, 2 successors, FD is 2681856
via 172.73.0.2 (2681856/2169856), Serial0/0/1
via 172.72.0.2 (2681856/2169856), Serial0/1/0
P 172.75.0.0/16, 1 successors, FD is 2681856
via 172.73.0.2 (2681856/2169856), Serial0/0/1

 

R1>show ip eigrp interfaces
IP-EIGRP interfaces for process 1

Xmit Queue Mean Pacing Time Multicast Pending
Interface Peers Un/Reliable SRTT Un/Reliable Flow Timer Routes
Fa0/0 0 0/0 1236 0/10 0 0
Se0/1/0 1 0/0 1236 0/10 0 0
Se0/0/0 1 0/0 1236 0/10 0 0
Se0/0/1 1 0/0 1236 0/10 0 0

 

 

Leave a Reply

Please log in using one of these methods to post your comment:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s