static routing configuration with each routers acting as a DHCP Machine

Posted: March 28, 2015 in CCNA

This article is all about how to configure static routing and at the same time create and configure dhcp pool on each routers to provide ip address to their related devices.In this lab i will show you how to configure static routing and also how to use each routers to assign ip address to the pc in their network dynamicaly through DHCP Server.Here we will configure DHCP Server on routers.

router as multiple dhcp machine

Lets  start configuring routers:

First we need to assign ip address to each and every interface of routers.After that we create dhcp pool on each routers.Then at last we do routing.

 

Configuration on Router R1:

 

— System Configuration Dialog —

Continue with configuration dialog? [yes/no]: no
Press RETURN to get started!

Router>enable
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname R1
R1(config)#int fa0/0
R1(config-if)#ip address 195.162.0.1 255.255.255.0
R1(config-if)#no shut

R1(config-if)#exit
R1(config)#int fa0/1
R1(config-if)#ip address 195.162.1.1 255.255.255.0
R1(config-if)#no shut
R1(config-if)#exit
R1(config)#ip dhcp pool Sw1
R1(dhcp-config)#network 195.162.0.0 255.255.255.0
R1(dhcp-config)#default-router 195.162.0.1

 

 

Configuration on Router R2:

— System Configuration Dialog —

Continue with configuration dialog? [yes/no]: no
Press RETURN to get started!

Router>enable
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname R2
R2(config)#int fa0/0
R2(config-if)#ip address 195.162.2.1 255.255.255.0
R2(config-if)#no shut

R2(config-if)#exit
R2(config)#int fa0/1
R2(config-if)#ip address 195.162.1.2 255.255.255.0
R2(config-if)#no shut

R2(config-if)#exit
R2(config)#int eth0/0/0
R2(config-if)#ip address 195.162.3.1 255.255.255.0
R2(config-if)#no shut
R2(config-if)#exit
R2(config)#ip dhcp pool Sw2
R2(dhcp-config)#network 195.162.2.0 255.255.255.0
R2(dhcp-config)#default-router 195.162.2.1

 

Configuration on Router R3:
— System Configuration Dialog —

Continue with configuration dialog? [yes/no]: no
Press RETURN to get started!

Router>enable
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname R3
R3(config)#int fa0/0
R3(config-if)#ip address 195.162.4.1 255.255.255.0
R3(config-if)#no shut

R3(config-if)#exit
R3(config)#int fa0/1
R3(config-if)#ip address 195.162.3.2 255.255.255.0
R3(config-if)#no shut

R3(config-if)#exit
R3(config)#int eth0/0/0
R3(config-if)#ip address 195.162.5.1 255.255.255.0
R3(config-if)#no shut
R3(config-if)#exit
R3(config)#ip dhcp pool sw3
R3(dhcp-config)#network 195.162.4.0 255.255.255.0
R3(dhcp-config)#default-router 195.162.4.1

 

 

Configuration on Router R4:
— System Configuration Dialog —

Continue with configuration dialog? [yes/no]: no
Press RETURN to get started!

Router>enable
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname R4
R4(config)#int fa0/0
R4(config-if)#ip address 195.162.6.1 255.255.255.0
R4(config-if)#no shut

R4(config-if)#exit
R4(config)#int fa0/1
R4(config-if)#ip address 195.162.5.2 255.255.255.0
R4(config-if)#no shut
R4(config-if)#exit
R4(config)#ip dhcp pool Sw4
R4(dhcp-config)#network 195.162.6.0 255.255.255.0
R4(dhcp-config)#default-router 195.162.6.1

 

Configure static route on Router R1:

R1(config)#ip route 195.162.2.0 255.255.255.0 195.162.1.2
R1(config)#ip route 195.162.3.0 255.255.255.0 195.162.1.2
R1(config)#ip route 195.162.4.0 255.255.255.0 195.162.1.2
R1(config)#ip route 195.162.5.0 255.255.255.0 195.162.1.2
R1(config)#ip route 195.162.6.0 255.255.255.0 195.162.1.2

 

Configure static route on Router R2:
R2(config)#ip route 195.162.0.0 255.255.255.0 195.162.1.1
R2(config)#ip route 195.162.4.0 255.255.255.0 195.162.3.2
R2(config)#ip route 195.162.5.0 255.255.255.0 195.162.3.2
R2(config)#ip route 195.162.6.0 255.255.255.0 195.162.3.2

 

Configure static route on Router R3:
R3(config)#ip route 195.162.2.0 255.255.255.0 195.162.3.1
R3(config)#ip route 195.162.1.0 255.255.255.0 195.162.3.1
R3(config)#ip route 195.162.0.0 255.255.255.0 195.162.3.1
R3(config)#ip route 195.162.6.0 255.255.255.0 195.162.5.2

 

Configure static route on Router R4:
R4(config)#ip route 195.162.4.0 255.255.255.0 195.162.5.1
R4(config)#ip route 195.162.3.0 255.255.255.0 195.162.5.1
R4(config)#ip route 195.162.2.0 255.255.255.0 195.162.5.1
R4(config)#ip route 195.162.1.0 255.255.255.0 195.162.5.1
R4(config)#ip route 195.162.0.0 255.255.255.0 195.162.5.1

 

Comments
  1. […] static routing configuration with each routers acting as a DHCP Machine […]

    Like

Leave a Reply

Please log in using one of these methods to post your comment:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s