In this tutorial we will learn how to configure IPv6 tunneling over IPv4.We configure IPv6 tunnel over IPv4 to encapsulate IPv6 traffic over IPv4 links.If you want to understand the whole mechanism you can think it as a method of transporting IPv6 packets across an IPv4 only Network.Here i have mentioned step wise method to configure IPv6 tunnel over IPv4 network in a very simple and straight forward way.

ipv6 tunnel over ipv4

Step 1:Configuration on Router R1:
 Router>enable
 Router#config t
 Enter configuration commands, one per line. End with CNTL/Z.
 Router(config)#host R1
 R1(config)#ipv6 unicast-routing
 R1(config)#int fa0/0
 R1(config-if)#ipv6 add 2000::1/64
 R1(config-if)#no shut

 

R1(config-if)#router eigrp 1
 R1(config-router)#exit
 R1(config)#router eigrp 1
 R1(config-router)#network 1.0.0.0 0.255.255.255
 R1(config-router)#

 

R1(config)#int fa0/1

R1(config-if)#ip add 1.0.0.1 255.0.0.0

R1(config-if)#no shut

 

 

 

Step 2:Configuration on Router R2:

 

Router>en

Router#config t

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#host R2

R2(config)#int fa0/0

R2(config-if)#ip add 1.0.0.2 255.0.0.0

R2(config-if)#no shut

 

R2(config-if)#exit

R2(config)#int fa0/1

R2(config-if)#ip add 2.0.0.1 255.0.0.0

R2(config-if)#no shut




R2(config-if)#exit

R2(config)#router eigrp 1

R2(config-router)#network 1.0.0.0 0.255.255.255

R2(config-router)#network 2.0.0.0 0.255.255.255

R2(config-router)#

 

 

Step 3:Configuration on Router R3:

 

Router>enable

Router#config t

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#host R3

R3(config)#ipv6 unicast-routing

R3(config)#int fa0/1

R3(config-if)#ipv6 add 2001::1/64

R3(config-if)#no shut

 

R3(config-if)#exit

R3(config)#int fa0/0

R3(config-if)#ip add 2.0.0.2 255.0.0.0

R3(config-if)#no shut

R3(config-if)#exit

R3(config)#router eigrp 1

R3(config-router)#network 2.0.0.0 0.255.255.255

 

IPv6 to IPv4 Configuration:

To configure ipv6 to ipv4 tunneling, we first need to create a tunnel interface on each dual-stack edge router.

There are three key components relevant to 6to4:

  • The tunnel mode (ipv6 to ipv4)
  • The tunnel source (IPv4 interface or address)
  • The 6to4 IPv6 address 
Step 4:Now Create Tunnel over Router R1:

 

R1(config)#int tunnel 0

R1(config-if)#tunnel source fa0/1

R1(config-if)#tunnel destination 2.0.0.2

R1(config-if)#tunnel mode ipv6ip

R1(config-if)#ipv6 address 2010::2/64

 

Step 5: Then Create Tunnel Over Router R3:

 

R3>enable

R3#config t

Enter configuration commands, one per line. End with CNTL/Z.

R3(config)#int fa0/0

R3(config-if)#int tunnel 0

R3(config-if)#tunnel source fa0/0

R3(config-if)#tunnel destination 1.0.0.1

R3(config-if)#tunnel mode ipv6ip

R3(config-if)#ipv6 address 2010::1/64

 

Step 6: Configure IPv6 static Route on Router R1:
R1(config)#ipv6 route 2001::/64 2010::1

 

Step 7:Configure Ipv6 Static Route on Router R3:

 

R3(config)#ipv6 route 2000::/64 2010::2
Step 8:Now test the Communication between both PC using ping command.

 

PC>ping 2000::2

Pinging 2000::2 with 32 bytes of data:

Reply from 2000::2: bytes=32 time=1ms TTL=126

Reply from 2000::2: bytes=32 time=0ms TTL=126

Reply from 2000::2: bytes=32 time=0ms TTL=126

Reply from 2000::2: bytes=32 time=0ms TTL=126

Ping statistics for 2000::2:

Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),

Approximate round trip times in milli-seconds:

Minimum = 0ms, Maximum = 1ms, Average = 0ms
Step 9: Now trace the path to destination IP to know the exact route:

 

First RUN the tracert command from PC0:

 

PC>tracert 2001::2

Tracing route to 2001::2 over a maximum of 30 hops:

1 0 ms 0 ms 0 ms 2000::1

2 0 ms 0 ms 0 ms 2010::1

3 0 ms 0 ms 1 ms 2001::2

Trace complete.

PC>

 

Now run the tracert command from PC1

 

PC>tracert 2000::2

Tracing route to 2000::2 over a maximum of 30 hops:

1 0 ms 0 ms 0 ms 2001::1

2 0 ms 0 ms 0 ms 2010::2

3 0 ms 0 ms 0 ms 2000::2

Trace complete.


Now see the Route of Router R1:
R1#show ipv6 route

IPv6 Routing Table - 6 entries

Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP

U - Per-user Static route, M - MIPv6

I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary

O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2

ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2

D - EIGRP, EX - EIGRP external

C 2000::/64 [0/0]

via ::, FastEthernet0/0

L 2000::1/128 [0/0]

via ::, FastEthernet0/0

S 2001::/64 [1/0]

via 2010::1

C 2010::/64 [0/0]

via ::, Tunnel0

L 2010::2/128 [0/0]

via ::, Tunnel0

L FF00::/8 [0/0]

via ::, Null0

 

 

SEE IPv4 Route table now:

 

R1#show ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

* - candidate default, U - per-user static route, o - ODR

P - periodic downloaded static route

Gateway of last resort is not set

C 1.0.0.0/8 is directly connected, FastEthernet0/1

D 2.0.0.0/8 [90/30720] via 1.0.0.2, 00:04:35, FastEthernet0/1
Advertisements
Comments
  1. TechFlax says:

    Super info..Satish..Keep it up 🙂 Thanks for sharing

    Like

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s